Chapter 5. Routing Information Protocol Version 2 (RIP-2)

RIP Version 2 is not a new protocol -- it is RIP Version 1 with some additional fields in the route update packet, key among them being subnet mask information in each route entry. The underlying DV algorithms in RIP-2 are identical to those in RIP-1, implying that RIP-2 still suffers from convergence problems and the maximum hop-count limit of 16 hops. Hence, RIP-2 may not be your choice as the routing protocol for a large or mid-sized network with multiple paths between segments. However, the new features in RIP-2 may be compelling enough for you to consider migrating an existing RIP-1 network to RIP-2. The new features in RIP-2 are summarized here:

Subnet mask

RIP-2 updates carry the subnet mask in each route entry, making RIP-2 a classless routing protocol that supports Variable Length Subnet Masks (VLSM), discontiguous address spaces, and CIDR blocks.

Next hop IP address

RIP-2 updates carry the next hop IP address in each route entry. As we will see later, the next hop IP address is useful when routes are being redistributed between RIP-2 and another routing protocol.

Authentication data

Every RIP-2 packet can carry authentication data to validate the source of the RIP-2 update. Remember that RIP-1 has no security features -- any host transmitting on UDP port 520 will be believed by neighbors running RIP-1.

Route tag

RIP-2 updates carry a tag in each route entry that is not used by RIP but could be used to represent information such as the source of the route when the route is imported from another AS (for example, BGP).

These additions to the RIP-1 update take the place of the unused or “must be zero” octets in the RIP-1 packet. This strategic placement has a major goal -- backward compatibility. Most versions of RIP-1 can process RIP-2 updates by ignoring the new fields.

Configuring and using RIP-2 is similar to RIP-1 and just as easy. A major reason for the long life of RIP may be the simplicity of the protocol and the ease of its use.

The next section gets RIP-2 running on TraderMary’s network.

Getting RIP-2 Running

RIP-1 -- a classful routing protocol -- does not support VLSM. We’ll configure TraderMary’s network using RIP-2 -- a classless routing protocol -- much like we did using RIP-1, but we will use VLSM. The distinction between classful and classless protocols and the support of VLSM are discussed in detail in the section Section 5.4.

TraderMary’s network is an ideal candidate for VLSM because of the mix of user segments and serial links in the 172.16.0.0 address space. Using a 24-bit mask (255.255.255.0) on Ethernet segments yields 254 addresses per segment for hosts. However, serial links require only 2 IP addresses -- using a 24-bit mask on a serial link wastes 252 addresses. A 30-bit mask (255.255.255.252) is more appropriate for a serial link, as it yields 2 usable IP addresses. How should 172.16.0.0 be segmented into 24-bit subnets for users on Ethernet segments and 30-bit subnets for serial links?

Using 24-bit masks (255.255.255.0) on Ethernet segments will give us 254 host addresses per user segment. Let’s first use this mask to subnet 172.16.0.0. The resulting subnets can be listed as follows:

  1. 172.16.1.0/24

  2. 172.16.2.0/24

  3. 172.16.3.0/24

  4. ...

  1. 172.16.253.0/24

  2. 172.16.254.0/24

Let’s now take one of these subnets (say, 172.15.250.0) and segment it further into 30-bit subnets for serial links. The resulting subnets can be listed as follows:

  1. 172.16.250.0/30

  2. 172.16.250.4/30

  3. 172.16.250.8/30

  4. 172.16.250.12/30

  5. ...

  1. 172.16.250.248/30

  2. 172.16.250.252/30

In these two lists we have carved the 172.16.0.0 address space using two subnet masks: 255.255.255.0 for users on Ethernet segments and 255.255.255.252 for serial links. Let’s recap the steps we took. First, we used the shorter mask (255.255.255.0) and listed the resulting subnets. Next, we used one subnet from the first step and subnetted it using the longer mask (255.255.255.252). The second step is sometimes referred to as sub-subnetting . If we were creating a nightmare of a network and had a third mask to work with as well, we would apply the third mask (the longest mask) on one or more subnets from either of the earlier steps. Following these steps ensures that we do not create overlapping subnets.

If TraderMary’s network ran out of all 64 30-bit subnets, another 24-bit subnet (say, 172.16.251.0) could be carved further to yield another 64 subnets.

See Figure 5-1 for the new addresses on TraderMary’s network.

TraderMary’s network with VLSM

Figure 5-1. TraderMary’s network with VLSM

The configuration for this network is as follows:

hostname NewYork
...
interface Ethernet0
ip address 172.16.1.1 255.255.255.0
!
interface Ethernet1
ip address 192.168.1.1 255.255.255.0
!
interface Serial0
description New York to Chicago link
ip address 172.16.250.1 255.255.255.252
!
interface Serial1
description New York to Ames link
bandwidth 56
ip address 172.16.250.5 255.255.255.252
...
router rip
version 2
network 172.16.0.0


hostname Chicago
...
interface Ethernet0
ip address 172.16.50.1 255.255.255.0
!
interface Serial0
description Chicago to New York link
ip address 172.16.250.2 255.255.255.252
!
interface Serial1
description Chicago to Ames link
ip address 172.16.250.9 255.255.255.0
...

router rip
version 2
network 172.16.0.0


hostname Ames
...
interface Ethernet0
ip address 172.16.100.1 255.255.255.0
!
interface Serial0
description Ames to Chicago link
ip address 172.16.250.10 255.255.255.0
!
interface Serial1
description Ames to New York link
bandwidth 56
ip address 172.16.250.6 255.255.255.0
...

router rip
version 2
network 172.16.0.0

Next, let’s verify that all the routers are seeing all the 172.16.0.0 subnets:

NewYork#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

Gateway of last resort is not set

C       192.168.1.0 is directly connected, Ethernet1
     172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
C       172.16.1.0/24 is directly connected, Ethernet0
C       172.16.250.0/30 is directly connected, Serial0
C       172.16.250.4/30 is directly connected, Serial1
R       172.16.50.0/24 [120/1] via 172.16.250.2, 0:00:11, Serial0
R       172.16.100.0/24 [120/1] via 172.16.250.6, 0:00:19, Serial1
R       172.16.250.8 [120/1] via 172.16.250.2, 0:00:11, Serial0
                     [120/1] via 172.16.250.6, 0:00:19, Serial1

Note that this routing table shows the mask associated with each subnet: /24 or /30.

RIP-2 is supported in Cisco IOS Versions 11.1 and later.

..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset