Appendix E. Solutions to Configuration Exercises

Chapter 1

1

If the first four bits of a class D address are 1110, the lowest first octet is 11100000 and the highest first octet is 11101111. In decimal these two numbers are 224 and 239, respectively. Therefore, the first octet of a class D address will range from 224 to 239.

2

(a) Enough subnet bits n are needed so that 2n – 2 > = 16,000. There must be enough host bits h remaining so that 2h – 2 > = 700. A subnet mask of 255.255.252.0 provides 16,382 subnets of the class A address, and 1022 host addresses on each subnet. This mask is the only one that works. If one more bit is used for subnetting (255.255.254.0), there will not be enough host addresses. If one less bit is used for subnetting (255.255.248.0), there will not be enough subnets.

(b) Enough subnet bits n are needed so that 2n – 2 > = 500. Enough host bits h must remain so that 2h – 2 > = 100. A subnet mask of 255.255.255.128 provides 510 subnets of the class B address and 126 host addresses on each subnet. Again, this mask is the only one that works.

3

With six bits of subnetting, a class C address will have 26 – 2 = 62 subnets and 22 – 2 = 2 host addresses per subnet. With this subnetting scheme, a single class C address can be used for 62 point-to-point links. A point-to-point link requires only two host addresses—one for each end of the link.

4

A class C address with a 28-bit mask will have 14 subnets and 14 host addresses on each subnet. The subnets are derived first.

The subnets are

11111111111111111111111111110000 = 255.255.255.240 (mask)11000000101010001001001100010000 = 192.168.147.1611000000101010001001001100100000 = 192.168.147.3211000000101010001001001100110000 = 192.168.147.4811000000101010001001001101000000 = 192.168.147.6411000000101010001001001101010000 = 192.168.147.8011000000101010001001001101100000 = 192.168.147.9611000000101010001001001101110000 = 192.168.147.11211000000101010001001001110000000 = 192.168.147.12811000000101010001001001110010000 = 192.168.147.14411000000101010001001001110100000 = 192.168.147.16011000000101010001001001110110000 = 192.168.147.17611000000101010001001001111000000 = 192.168.147.19211000000101010001001001111010000 = 192.168.147.20811000000101010001001001111100000 = 192.168.147.224

Next, the host addresses for each subnet are derived. The broadcast addresses for each subnet are also shown.

The host addresses for each subnet are

11000000101010001001001100010000 = 192.168.147.16 (subnet)11000000101010001001001100010001 = 192.168.147.1711000000101010001001001100010010 = 192.168.147.1811000000101010001001001100010011 = 192.168.147.1911000000101010001001001100010100 = 192.168.147.2011000000101010001001001100010101 = 192.168.147.2111000000101010001001001100010110 = 192.168.147.2211000000101010001001001100010111 = 192.168.147.2311000000101010001001001100011000 = 192.168.147.2411000000101010001001001100011001 = 192.168.147.2511000000101010001001001100011010 = 192.168.147.2611000000101010001001001100011011 = 192.168.147.2711000000101010001001001100011100 = 192.168.147.2811000000101010001001001100011101 = 192.168.147.2911000000101010001001001100011110 = 192.168.147.3011000000101010001001001100011111 = 192.168.147.31 (broadcast)11000000101010001001001100100000 = 192.168.147.32 (subnet)11000000101010001001001100100001 = 192.168.147.3311000000101010001001001100100010 = 192.168.147.3411000000101010001001001100100011 = 192.168.147.3511000000101010001001001100100100 = 192.168.147.3611000000101010001001001100100101 = 192.168.147.3711000000101010001001001100100110 = 192.168.147.3811000000101010001001001100100111 = 192.168.147.3911000000101010001001001100101000 = 192.168.147.4011000000101010001001001100101001 = 192.168.147.4111000000101010001001001100101010 = 192.168.147.4211000000101010001001001100101011 = 192.168.147.4311000000101010001001001100101100 = 192.168.147.4411000000101010001001001100101101 = 192.168.147.4511000000101010001001001100101110 = 192.168.147.4611000000101010001001001100101111 = 192.168.147.47 (broadcast)11000000101010001001001100110000 = 192.168.147.48 (subnet)11000000101010001001001100110001 = 192.168.147.4911000000101010001001001100110010 = 192.168.147.5011000000101010001001001100110011 = 192.168.147.5111000000101010001001001100110100 = 192.168.147.5211000000101010001001001100110101 = 192.168.147.5311000000101010001001001100110110 = 192.168.147.5411000000101010001001001100110111 = 192.168.147.5511000000101010001001001100111000 = 192.168.147.5611000000101010001001001100111001 = 192.168.147.5711000000101010001001001100111010 = 192.168.147.5811000000101010001001001100111011 = 192.168.147.5911000000101010001001001100111100 = 192.168.147.6011000000101010001001001100111101 = 192.168.147.6111000000101010001001001100111110 = 192.168.147.6211000000101010001001001100111111 = 192.168.147.63 (broadcast)11000000101010001001001101000000 = 192.168.147.64 (subnet)11000000101010001001001101000001 = 192.168.147.6511000000101010001001001101000010 = 192.168.147.6611000000101010001001001101000011 = 192.168.147.6711000000101010001001001101000100 = 192.168.147.6811000000101010001001001101000101 = 192.168.147.6911000000101010001001001101000110 = 192.168.147.7011000000101010001001001101000111 = 192.168.147.7111000000101010001001001101001000 = 192.168.147.7211000000101010001001001101001001 = 192.168.147.7311000000101010001001001101001010 = 192.168.147.7411000000101010001001001101001011 = 192.168.147.7511000000101010001001001101001100 = 192.168.147.7611000000101010001001001101001101 = 192.168.147.7711000000101010001001001101001110 = 192.168.147.7811000000101010001001001101001111 = 192.168.147.79 (broadcast)11000000101010001001001101010000 = 192.168.147.80 (subnet)11000000101010001001001101010001 = 192.168.147.8111000000101010001001001101010010 = 192.168.147.8211000000101010001001001101010011 = 192.168.147.8311000000101010001001001101010100 = 192.168.147.8411000000101010001001001101010101 = 192.168.147.8511000000101010001001001101010110 = 192.168.147.8611000000101010001001001101010111 = 192.168.147.8711000000101010001001001101011000 = 192.168.147.8811000000101010001001001101011001 = 192.168.147.8911000000101010001001001101011010 = 192.168.147.9011000000101010001001001101011011 = 192.168.147.9111000000101010001001001101011100 = 192.168.147.9211000000101010001001001101011101 = 192.168.147.9311000000101010001001001101011110 = 192.168.147.9411000000101010001001001101011111 = 192.168.147.95 (broadcast)11000000101010001001001101100000 = 192.168.147.96 (subnet)11000000101010001001001101100001 = 192.168.147.9711000000101010001001001101100010 = 192.168.147.9811000000101010001001001101100011 = 192.168.147.9911000000101010001001001101100100 = 192.168.147.10011000000101010001001001101100101 = 192.168.147.10111000000101010001001001101100110 = 192.168.147.10211000000101010001001001101100111 = 192.168.147.10311000000101010001001001101101000 = 192.168.147.10411000000101010001001001101101001 = 192.168.147.10511000000101010001001001101101010 = 192.168.147.10611000000101010001001001101101011 = 192.168.147.10711000000101010001001001101101100 = 192.168.147.10811000000101010001001001101101101 = 192.168.147.10911000000101010001001001101101110 = 192.168.147.11011000000101010001001001101101111 = 192.168.147.111 (broadcast)11000000101010001001001101110000 = 192.168.147.112 (subnet)11000000101010001001001101110001 = 192.168.147.11311000000101010001001001101110010 = 192.168.147.11411000000101010001001001101110011 = 192.168.147.11511000000101010001001001101110100 = 192.168.147.11611000000101010001001001101110101 = 192.168.147.11711000000101010001001001101110110 = 192.168.147.11811000000101010001001001101110111 = 192.168.147.11911000000101010001001001101111000 = 192.168.147.12011000000101010001001001101111001 = 192.168.147.12111000000101010001001001101111010 = 192.168.147.12211000000101010001001001101111011 = 192.168.147.12311000000101010001001001101111100 = 192.168.147.12411000000101010001001001101111101 = 192.168.147.12511000000101010001001001101111110 = 192.168.147.12611000000101010001001001101111111 = 192.168.147.127 (broadcast)11000000101010001001001110000000 = 192.168.147.128 (subnet)11000000101010001001001110000001 = 192.168.147.12911000000101010001001001110000010 = 192.168.147.13011000000101010001001001110000011 = 192.168.147.13111000000101010001001001110000100 = 192.168.147.13211000000101010001001001110000101 = 192.168.147.13311000000101010001001001110000110 = 192.168.147.13411000000101010001001001110000111 = 192.168.147.13511000000101010001001001110001000 = 192.168.147.13611000000101010001001001110001001 = 192.168.147.13711000000101010001001001110001010 = 192.168.147.13811000000101010001001001110001011 = 192.168.147.13911000000101010001001001110001100 = 192.168.147.14011000000101010001001001110001101 = 192.168.147.14111000000101010001001001110001110 = 192.168.147.14211000000101010001001001110001111 = 192.168.147.143 (broadcast)11000000101010001001001110010000 = 192.168.147.144 (subnet)11000000101010001001001110010001 = 192.168.147.14511000000101010001001001110010010 = 192.168.147.14611000000101010001001001110010011 = 192.168.147.14711000000101010001001001110010100 = 192.168.147.14811000000101010001001001110010101 = 192.168.147.14911000000101010001001001110010110 = 192.168.147.15011000000101010001001001110010111 = 192.168.147.15111000000101010001001001110011000 = 192.168.147.15211000000101010001001001110011001 = 192.168.147.15311000000101010001001001110011010 = 192.168.147.15411000000101010001001001110011011 = 192.168.147.15511000000101010001001001110011100 = 192.168.147.15611000000101010001001001110011101 = 192.168.147.15711000000101010001001001110011110 = 192.168.147.15811000000101010001001001110011111 = 192.168.147.159 (broadcast)11000000101010001001001110100000 = 192.168.147.160 (subnet)11000000101010001001001110100001 = 192.168.147.16111000000101010001001001110100010 = 192.168.147.16211000000101010001001001110100011 = 192.168.147.16311000000101010001001001110100100 = 192.168.147.16411000000101010001001001110100101 = 192.168.147.16511000000101010001001001110100110 = 192.168.147.16611000000101010001001001110100111 = 192.168.147.16711000000101010001001001110101000 = 192.168.147.16811000000101010001001001110101001 = 192.168.147.16911000000101010001001001110101010 = 192.168.147.17011000000101010001001001110101011 = 192.168.147.17111000000101010001001001110101100 = 192.168.147.17211000000101010001001001110101101 = 192.168.147.17311000000101010001001001110101110 = 192.168.147.17411000000101010001001001110101111 = 192.168.147.175 (broadcast)11000000101010001001001110110000 = 192.168.147.176 (subnet)11000000101010001001001110110001 = 192.168.147.17711000000101010001001001110110010 = 192.168.147.17811000000101010001001001110110011 = 192.168.147.17911000000101010001001001110110100 = 192.168.147.18011000000101010001001001110110101 = 192.168.147.18111000000101010001001001110110110 = 192.168.147.18211000000101010001001001110110111 = 192.168.147.18311000000101010001001001110111000 = 192.168.147.18411000000101010001001001110111001 = 192.168.147.18511000000101010001001001110111010 = 192.168.147.18611000000101010001001001110111011 = 192.168.147.18711000000101010001001001110111100 = 192.168.147.18811000000101010001001001110111101 = 192.168.147.18911000000101010001001001110111110 = 192.168.147.19011000000101010001001001110111111 = 192.168.147.191 (broadcast)11000000101010001001001111000000 = 192.168.147.192 (subnet)11000000101010001001001111000001 = 192.168.147.19311000000101010001001001111000010 = 192.168.147.19411000000101010001001001111000011 = 192.168.147.19511000000101010001001001111000100 = 192.168.147.19611000000101010001001001111000101 = 192.168.147.19711000000101010001001001111000110 = 192.168.147.19811000000101010001001001111000111 = 192.168.147.19911000000101010001001001111001000 = 192.168.147.20011000000101010001001001111001001 = 192.168.147.20111000000101010001001001111001010 = 192.168.147.20211000000101010001001001111001011 = 192.168.147.20311000000101010001001001111001100 = 192.168.147.20411000000101010001001001111001101 = 192.168.147.20511000000101010001001001111001110 = 192.168.147.20611000000101010001001001111001111 = 192.168.147.207 (broadcast)11000000101010001001001111010000 = 192.168.147.208 (subnet)11000000101010001001001111010001 = 192.168.147.20911000000101010001001001111010010 = 192.168.147.21011000000101010001001001111010011 = 192.168.147.21111000000101010001001001111010100 = 192.168.147.21211000000101010001001001111010101 = 192.168.147.21311000000101010001001001111010110 = 192.168.147.21411000000101010001001001111010111 = 192.168.147.21511000000101010001001001111011000 = 192.168.147.21611000000101010001001001111011001 = 192.168.147.21711000000101010001001001111011010 = 192.168.147.21811000000101010001001001111011011 = 192.168.147.21911000000101010001001001111011100 = 192.168.147.22011000000101010001001001111011101 = 192.168.147.22111000000101010001001001111011110 = 192.168.147.22211000000101010001001001111011111 = 192.168.147.223 (broadcast)11000000101010001001001111100000 = 192.168.147.224 (subnet)11000000101010001001001111100001 = 192.168.147.22511000000101010001001001111100010 = 192.168.147.22611000000101010001001001111100011 = 192.168.147.22711000000101010001001001111100100 = 192.168.147.22811000000101010001001001111100101 = 192.168.147.22911000000101010001001001111100110 = 192.168.147.23011000000101010001001001111100111 = 192.168.147.23111000000101010001001001111101000 = 192.168.147.23211000000101010001001001111101001 = 192.168.147.23311000000101010001001001111101010 = 192.168.147.23411000000101010001001001111101011 = 192.168.147.23511000000101010001001001111101100 = 192.168.147.23611000000101010001001001111101101 = 192.168.147.23711000000101010001001001111101110 = 192.168.147.23811000000101010001001001111101111 = 192.168.147.239 (broadcast)

5

This solution shows a shorter technique than the last solution in which every host address of every subnet was written out.

A class C address with a 29-bit mask means that there will be 30 subnets and 6 host addresses on each subnet.

The subnets are

11111111111111111111111111111000 = 255.255.255.248 (mask)11000000101010001001001100001000 = 192.168.147.811000000101010001001001100010000 = 192.168.147.1611000000101010001001001100011000 = 192.168.147.2411000000101010001001001100100000 = 192.168.147.3211000000101010001001001100101000 = 192.168.147.4011000000101010001001001100110000 = 192.168.147.4811000000101010001001001100111000 = 192.168.147.5611000000101010001001001101000000 = 192.168.147.6411000000101010001001001101001000 = 192.168.147.7211000000101010001001001101010000 = 192.168.147.8011000000101010001001001101011000 = 192.168.147.8811000000101010001001001101100000 = 192.168.147.9611000000101010001001001101101000 = 192.168.147.10411000000101010001001001101100000 = 192.168.147.11211000000101010001001001101111000 = 192.168.147.12011000000101010001001001110000000 = 192.168.147.12811000000101010001001001110001000 = 192.168.147.13611000000101010001001001110010000 = 192.168.147.14411000000101010001001001110011000 = 192.168.147.15211000000101010001001001110100000 = 192.168.147.16011000000101010001001001110101000 = 192.168.147.16811000000101010001001001110110000 = 192.168.147.17611000000101010001001001110111000 = 192.168.147.18411000000101010001001001111000000 = 192.168.147.19211000000101010001001001111001000 = 192.168.147.20011000000101010001001001111010000 = 192.168.147.20811000000101010001001001111011000 = 192.168.147.21611000000101010001001001111100000 = 192.168.147.22411000000101010001001001111101000 = 192.168.147.23211000000101010001001001111110000 = 192.168.147.240

Next, the broadcast addresses of each subnet are derived by setting the host bits of each subnet to all ones.

The subnet broadcast addresses are

11000000101010001001001100001111 = 192.168.147.1511000000101010001001001100010111 = 192.168.147.2311000000101010001001001100011111 = 192.168.147.3111000000101010001001001100100111 = 192.168.147.3911000000101010001001001100101111 = 192.168.147.4711000000101010001001001100110111 = 192.168.147.5511000000101010001001001100111111 = 192.168.147.6311000000101010001001001101000111 = 192.168.147.7111000000101010001001001101001111 = 192.168.147.7911000000101010001001001101010111 = 192.168.147.8711000000101010001001001101011111 = 192.168.147.9511000000101010001001001101100111 = 192.168.147.10311000000101010001001001101101111 = 192.168.147.11111000000101010001001001101100111 = 192.168.147.11911000000101010001001001101111111 = 192.168.147.12711000000101010001001001110000111 = 192.168.147.13511000000101010001001001110001111 = 192.168.147.14311000000101010001001001110010111 = 192.168.147.15111000000101010001001001110011111 = 192.168.147.15911000000101010001001001110100111 = 192.168.147.16711000000101010001001001110101111 = 192.168.147.17511000000101010001001001110110111 = 192.168.147.18311000000101010001001001110111111 = 192.168.147.19111000000101010001001001111000111 = 192.168.147.19911000000101010001001001111001111 = 192.168.147.20711000000101010001001001111010111 = 192.168.147.21511000000101010001001001111011111 = 192.168.147.22311000000101010001001001111100111 = 192.168.147.23111000000101010001001001111101111 = 192.168.147.23911000000101010001001001111110111 = 192.168.147.247

Finally, the host addresses for each subnet are derived. They will be all addresses between the subnet addresses and the subnet broadcast addresses.

Subnet

Broadcast

Host Addresses

192.168.147.8

192.168.147.15

192.168.147.9–192.168.147.14

192.168.147.16

192.168.147.23

192.168.147.17–192.168.147.22

192.168.147.24

192.168.147.31

192.168.147.25–192.168.147.30

192.168.147.32

192.168.147.39

192.168.147.33–192.168.147.38

192.168.147.40

192.168.147.47

192.168.147.41–192.168.147.46

192.168.147.48

192.168.147.55

192.168.147.49–192.168.147.54

192.168.147.56

192.168.147.63

192.168.147.57–192.168.147.62

192.168.147.64

192.168.147.71

192.168.147.65–192.168.147.70

192.168.147.72

192.168.147.79

192.168.147.73–192.168.147.78

192.168.147.80

192.168.147.87

192.168.147.81–192.168.147.86

192.168.147.88

192.168.147.95

192.168.147.89–192.168.147.94

192.168.147.96

192.168.147.103

192.168.147.97–192.168.147.102

192.168.147.104

192.168.147.111

192.168.147.105–192.168.147.110

192.168.147.112

192.168.147.119

192.168.147.113–192.168.147.118

192.168.147.120

192.168.147.127

192.168.147.121–192.168.147.126

192.168.147.128

192.168.147.135

192.168.147.129–192.168.147.134

192.168.147.136

192.168.147.143

192.168.147.137–192.168.147.142

192.168.147.144

192.168.147.151

192.168.147.145–192.168.147.150

192.168.147.152

192.168.147.159

192.168.147.153–192.168.147.158

192.168.147.160

192.168.147.167

192.168.147.161–192.168.147.166

192.168.147.168

192.168.147.175

192.168.147.169–192.168.147.174

6

A class B address with a 20-bit mask will have 14 subnets and 4,094 host addresses on each subnet.

The subnets are

11111111111111111111000000000000 = 255.255.240.0 (mask)10101100000100000001000000000000 = 172.16.16.010101100000100000010000000000000 = 172.16.32.010101100000100000011000000000000 = 172.16.48.010101100000100000100000000000000 = 172.16.64.010101100000100000101000000000000 = 172.16.80.010101100000100000110000000000000 = 172.16.96.010101100000100000111000000000000 = 172.16.112.010101100000100001000000000000000 = 172.16.128.010101100000100001001000000000000 = 172.16.144.010101100000100001010000000000000 = 172.16.160.010101100000100001011000000000000 = 172.16.176.010101100000100001100000000000000 = 172.16.192.010101100000100001101000000000000 = 172.16.208.010101100000100001110000000000000 = 172.16.224.0

The subnet broadcast addresses are

10101100000100000001111111111111 = 172.16.31.25510101100000100000010111111111111 = 172.16.47.25510101100000100000011111111111111 = 172.16.63.25510101100000100000100111111111111 = 172.16.79.25510101100000100000101111111111111 = 172.16.95.25510101100000100000110111111111111 = 172.16.111.25510101100000100000111111111111111 = 172.16.127.25510101100000100001000111111111111 = 172.16.143.25510101100000100001001111111111111 = 172.16.159.25510101100000100001010111111111111 = 172.16.175.25510101100000100001011111111111111 = 172.16.191.25510101100000100001100111111111111 = 172.16.207.25510101100000100001101111111111111 = 172.16.223.25510101100000100001110111111111111 = 172.16.239.255

Using the derived subnet and broadcast addresses, the host addresses are as follows.

Subnet

Broadcast

Host Addresses

172.16.16.0

172.16.31.255

172.16.16.1–172.16.31.254

172.16.32.0

172.16.47.255

172.16.32.1–172.16.47.254

172.16.48.0

172.16.63.255

172.16.48.1–172.16.63.254

172.16.64.0

172.16.79.255

172.16.64.1–172.16.79.254

172.16.80.0

172.16.95.255

172.16.80.1–172.16.95.254

172.16.96.0

172.16.111.255

172.16.96.1–172.16.111.254

172.16.112.0

172.16.127.255

172.16.112.1–172.16.127.254

172.16.128.0

172.16.143.255

172.16.128.1–172.16.143.254

172.16.144.0

172.16.159.255

172.16.144.1–172.16.159.254

172.16.160.0

172.16.175.255

172.16.160.1–172.16.175.254

172.16.176.0

172.16.191.255

172.16.176.1–172.16.191.254

172.16.192.0

172.16.207.255

172.16.192.1–172.16.207.254

172.16.208.0

172.16.223.255

172.16.208.1–172.16.223.254

172.16.224.0

172.16.239.255

172.224.16.1–172.16.239.254

Chapter 3

1

First determine the subnet addresses of each link and then write the static routes. Remember that the routers will already have entries in their route tables for any directly connected subnet. The static routes are as follows:

RTA:

ip route 192.168.2.64 255.255.255.224 192.168.2.131
ip route 192.168.2.160 255.255.255.224 192.168.2.131
ip route 192.168.1.128 255.255.255.240 192.168.2.131
ip route 192.168.1.16 255.255.255.240 192.168.2.131
ip route 192.168.2.32 255.255.255.224 192.168.2.131
ip route 192.168.1.160 255.255.255.240 192.168.2.131
ip route 10.1.1.0 255.255.255.0 192.168.2.131
ip route 10.1.3.0 255.255.255.0 192.168.2.131
ip route 10.1.2.0 255.255.255.0 192.168.2.131

RTB:

ip route 10.1.4.0 255.255.255.0 192.168.2.132
ip route 192.168.1.128 255.255.255.240 192.168.2.174
ip route 192.168.1.16 255.255.255.240 192.168.2.174
ip route 192.168.2.32 255.255.255.224 192.168.2.174
ip route 192.168.1.160 255.255.255.240 192.168.2.174
ip route 10.1.1.0 255.255.255.0 192.168.2.174
ip route 10.1.3.0 255.255.255.0 192.168.2.174
ip route 10.1.2.0 255.255.255.0 192.168.2.174

RTC:

ip route 10.1.4.0 255.255.255.0 192.168.2.185
ip route 192.168.2.128 255.255.255.224 192.168.2.185
ip route 192.168.2.64 255.255.255.224 192.168.2.185
ip route 192.168.2.32 255.255.255.224 192.168.1.20
ip route 10.1.1.0 255.255.255.0 192.168.1.173
ip route 10.1.3.0 255.255.255.0 192.168.1.173
ip route 10.1.2.0 255.255.255.0 192.168.1.173

RTD:

ip route 10.1.4.0 255.255.255.0 192.168.1.29
ip route 192.168.2.128 255.255.255.224 192.168.1.29
ip route 192.168.2.64 255.255.255.224 192.168.1.29
ip route 192.168.2.160 255.255.255.224 192.168.1.29
ip route 192.168.1.128 255.255.255.240 192.168.1.29
ip route 192.168.1.160 255.255.255.240 192.168.1.29
ip route 10.1.1.0 255.255.255.0 192.168.1.29
ip route 10.1.3.0 255.255.255.0 192.168.1.29
ip route 10.1.2.0 255.255.255.0 192.168.1.29

RTE:

ip route 10.1.4.0 255.255.255.0 192.168.1.163
ip route 192.168.2.128 255.255.255.224 192.168.1.163
ip route 192.168.2.64 255.255.255.224 192.168.1.163
ip route 192.168.2.160 255.255.255.224 192.168.1.163
ip route 192.168.1.128 255.255.255.240 192.168.1.163
ip route 192.168.1.16 255.255.255.240 192.168.1.163
ip route 192.168.2.32 255.255.255.224 192.168.1.163
ip route 10.1.2.0 255.255.255.0 10.1.3.2

RTF:

ip route 10.1.4.0 255.255.255.0 10.1.3.1
ip route 192.168.2.128 255.255.255.224 10.1.3.1
ip route 192.168.2.64 255.255.255.224 10.1.3.1
ip route 192.168.2.160 255.255.255.224 10.1.3.1
ip route 192.168.1.128 255.255.255.240 10.1.3.1
ip route 192.168.1.16 255.255.255.240 10.1.3.1
ip route 192.168.2.32 255.255.255.224 10.1.3.1
ip route 192.168.1.160 255.255.255.240 10.1.3.1
ip route 10.1.1.0 255.255.255.0 10.1.3.1

2

The static routes are as follows:

RTA:

ip route 192.168.0.0 255.255.0.0 192.168.2.131
ip route 10.1.0.0 255.255.0.0 192.168.2.131

RTB:

ip route 10.1.4.0 255.255.255.0 192.168.2.132
ip route 192.168.0.0 255.255.0.0 192.168.2.174
ip route 10.1.0.0 255.255.0.0 192.168.2.174

RTC:

ip route 10.1.4.0 255.255.255.0 192.168.2.185
ip route 192.168.2.32 255.255.255.224 192.168.1.20
ip route 10.1.0.0 255.255.0.0 192.168.1.173
ip route 192.168.2.64 255.255.255.224 192.168.2.185
ip route 192.168.2.128 255.255.255.224 192.168.2.185

RTD:

ip route 10.1.0.0 255.255.0.0 192.168.1.29
ip route 192.168.0.0 255.255.05.0 192.168.1.29

RTE

ip route 10.1.4.0 255.255.255.0 192.168.1.163
ip route 192.168.0.0 255.255.0.0 192.168.1.163
ip route 10.1.2.0 255.255.255.0 10.1.3.2

RTF:

ip route 10.1.0.0 255.255.0.0 10.1.3.1
ip route 192.168.0.0 255.255.0.0 10.1.3.1

3

The static routes are as follows:

RTA:

ip route 172.16.7.0 255.255.255.0 172.16.2.2
ip route 172.16.7.0 255.255.255.0 172.16.4.2 50
ip route 172.16.6.0 255.255.255.0 172.16.2.2
ip route 172.16.6.0 255.255.255.0 172.16.4.2 50
ip route 172.16.8.0 255.255.255.0 172.16.4.2
ip route 172.16.8.0 255.255.255.0 172.16.2.2 50
ip route 172.16.5.0 255.255.255.0 172.16.4.2
ip route 172.16.5.0 255.255.255.0 172.16.2.2 50
ip route 172.16.9.0 255.255.255.0 172.16.2.2
ip route 172.16.9.0 255.255.255.0 172.16.4.2

RTB:

ip route 172.16.1.0 255.255.255.0 172.16.2.1
ip route 172.16.1.0 255.255.255.0 172.16.6.1 50
ip route 172.16.4.0 255.255.255.0 172.16.2.1
ip route 172.16.4.0 255.255.255.0 172.16.6.1 50
ip route 172.16.9.0 255.255.255.0 172.16.6.1
ip route 172.16.9.0 255.255.255.0 172.16.2.1 50
ip route 172.16.5.0 255.255.255.0 172.16.6.1
ip route 172.16.5.0 255.255.255.0 172.16.2.1 50
ip route 172.16.8.0 255.255.255.0 172.16.6.1
ip route 172.16.8.0 255.255.255.0 172.16.2.1

RTC:

ip route 172.16.1.0 255.255.255.0 172.16.6.2
ip route 172.16.1.0 255.255.255.0 172.16.5.1
ip route 172.16.4.0 255.255.255.0 172.16.5.1
ip route 172.16.4.0 255.255.255.0 172.16.6.2 50
ip route 172.16.2.0 255.255.255.0 172.16.6.2
ip route 172.16.2.0 255.255.255.0 172.16.5.1 50
ip route 172.16.7.0 255.255.255.0 172.16.6.2
ip route 172.16.7.0 255.255.255.0 172.16.5.1 50
ip route 172.16.8.0 255.255.255.0 172.16.5.1
ip route 172.16.8.0 255.255.255.0 172.16.6.2 50

RTD:

ip route 172.16.1.0 255.255.255.0 172.16.4.1
ip route 172.16.1.0 255.255.255.0 172.16.5.2 50
ip route 172.16.2.0 255.255.255.0 172.16.4.1
ip route 172.16.2.0 255.255.255.0 172.16.5.2 50
ip route 172.16.9.0 255.255.255.0 172.16.5.2
ip route 172.16.9.0 255.255.255.0 172.16.4.1 50
ip route 172.16.6.0 255.255.255.0 172.16.5.2
ip route 172.16.6.0 255.255.255.0 172.16.4.1 50
ip route 172.16.7.0 255.255.255.0 172.16.5.2
ip route 172.16.7.0 255.255.255.0 172.16.4.1

Chapter 5

1

In addition to the RIP configurations shown here, a subnet of 192.168.5.0 must be configured between RTE and RTF, using secondary addresses. Otherwise, subnets 192.168.5.192/27 and 192.168.5.96/27 are discontiguous. The RIP configurations are

RTA:

router rip
  network 192.168.2.0

RTB:

router rip
  network 192.168.2.0

RTC:

router rip
  network 192.168.2.0
  network 192.168.3.0

RTD:

interface ethernet 0
  ip address 192.168.4.3 255.255.255.0
  ip address 192.168.5.3 255.255.255.224 secondary
router rip
  network 192.168.3.0
  network 192.168.4.0

RTE:

interface ethernet 0
  ip address 192.168.4.1 255.255.255.0
  ip address 192.168.5.1 255.255.255.224 secondary
router rip
  network 192.168.4.0
  network 192.168.5.0

RTF:

interface ethernet 0
  ip address 192.168.4.2 255.255.255.0
  ip address 192.168.5.2 255.255.255.224 secondary
router rip
  network 192.168.4.0
  network 192.168.6.0

2

To unicast RIP updates between RTC and RTD, the configurations are

RTC:

router rip
  network 192.168.2.0
  neighbor 192.168.3.2

RTD:

router rip
  network 192.168.3.0
  neighbor 192.168.3.1

3

The update time applies to the entire RIP process. If the update time is changed for the serial link, it will also be changed for the router’s other links. That, in turn, means that the timers must be changed on the neighboring routers, which means those neighbors’ neighbors must be changed, and so on. The cascade effect of changing the update timer on a single router means that the timers must be changed on every router in the RIP domain. The command to increase the RIP update period to two minutes, configured on every router, is

timers basic 120 360 360 480

Because the update timer is changed, the invalid, holddown, and flush timers must also be changed. Setting the invalid and holddown timers to six times the update period, as the default timers are, would make the conversion time of the network extremely high. Therefore, the invalid and holddown timers are set to three times the update period. The flush timer must be longer than the holddown timer, so it is set to 60 seconds longer.

4

Network 192.168.4.0 is two hops from RTA, so adding 14 to the metric will give the route an unreachable metric of 16. Remember that in Configuration Exercise 1 a subnet of 192.168.5.0 had to be configured on the same link as 192.168.4.0 using secondary addresses, so that the subnets of 192.168.5.0 are contiguous. Therefore, 192.168.5.0 is also two hops from RTB. Assuming the interfaces of RTA and RTB connected to RTC are E0 on both routers, the configurations are

RTA:

router rip
offset-list 1 in 14 Ethernet0
network 192.168.2.0
!
access-list 1 permit 192.168.4.0 0.0.0.0

RTB:

router rip
offset-list 1 in 14 Ethernet0
network 192.168.2.0
!
access-list 1 permit 192.168.5.0 0.0.0.0

5

RTB, with its longer mask, can interpret all subnets correctly. The problem is at RTA. With a 27-bit mask, RTA interprets RTB’s subnets 192.168.20.40/29 and 192.168.20.49/29 as 192.168.20.32/27—the same subnet as its directly connected link. Therefore, RTA does not have a correct “view” of the network.

However, packets can still be routed if Proxy ARP is enabled. For example, suppose RTA has a packet to forward with a destination address of 192.168.20.50. RTA incorrectly interprets this address as a member of its subnet 192.168.20.32/27, and ARPs for the MAC identifier of 192.168.20.50 on that subnet. RTB hears the ARP; it correctly interprets 192.168.20.50 as being a member of its subnet 192.168.20.48/29 and responds with the MAC identifier of its interface on 192.168.20.32/29. RTA then forwards the packet to RTB, and RTB forwards the packet to the correct destination. If Proxy ARP is disabled, packets will not be delivered correctly from RTA to RTB.

Chapter 6

1

The statement neighbor 172.25.150.206 can be added to Taos’s RIP configuration, causing Taos to unicast RIP updates to that address. This approach works only if Pojoaque’s RIPv1 process complies with the rule that the unused fields of RIP messages with version numbers higher than 1 will be ignored and the rest of the packet processed.

2

Begin by calculating the subnets with the highest number of hosts. From the unused subnet bits, calculate the subnet(s) with the next-highest number of hosts, and so on. Remember that as a group of bits are used for a subnet, no subsequent subnet can begin with that same bit combination. For example, if the first subnet begins with 00, all subsequent subnets must begin with 01, 10, or 11. If the second subnet begins with 010, no subsequent subnet can begin with 010.

One solution (with the subnet bits shaded) is

00000000

192.168.100.0/26 (62 hosts)

01000000

192.168.100.64/27 (30 hosts)

01100000

192.168.100.96/28 (14 hosts)

01110000

192.168.100.112/28 (14 hosts)

10000000

192.168.100.128/28 (14 hosts)

10010000

192.168.100.144/28 (14 hosts)

10100000

192.168.100.160/28 (14 hosts)

10110000

192.168.100.176/29 (8 hosts)

10111000

192.168.100.184/29 (8 hosts)

11000000

192.168.100.192/29 (8 hosts)

11001000

192.168.100.200/29 (8 hosts)

11010000

192.168.100.208/29 (8 hosts)

11011000

192.168.100.216/30 (2 hosts)

11011100

192.168.100.220/30 (2 hosts)

11100000

192.168.100.224/30 (2 hosts)

11100100

192.168.100.228/30 (2 hosts)

11101000

192.168.100.232/30 (2 hosts)

11101100

192.168.100.236/30 (2 hosts)

11110000

192.168.100.240/30 (2 hosts)

11110100

192.168.100.244/30 (2 hosts)

11111000

192.168.100.248/30 (2 hosts)

11111100

192.168.100.252/30 (2 hosts)

3

RTA, RTB, and RTD have the statement version 2 in their RIP configurations. Additionally, the RIP configurations of RTA and RTB include the statement no auto-summary. The interfaces of RTA and RTB connected to subnet 192.168.2.64/28 have the statements ip rip send version 1 2 and ip rip receive version 1 2. The interface of RTD connected to subnet 192.168.2.128/28 has the statements ip rip send version 1 and ip rip receive version 1.

4

The following solution uses a key chain name of CCIE and a key string named exercise4 on RTB and RTD. Assuming both routers’ interfaces are S0, the configuration of both RTB and RTD is

key chain CCIE
  key 1
    key-string exercise4
!
interface Serial0
  ip address 192.168.1.15X 255.255.255.252
  ip rip authentication mode md5
  ip rip authentication key-chain CCIE

5

The configuration here assumes that the authentication key in Configuration Exercise 4 was enabled on October 31, 2004, at midnight. The second key string used here is exercise5a, and the third key string is exercise5b:

key chain CCIE
  key 1
    key-string exercise4
    accept-lifetime 00:00:00 Oct 31 2004 00:00:00 Nov 3 2004
    send-lifetime 00:00:00 Oct 31 2004 00:30:00 Nov 3 2004
  key 2
    key-string exercise5a
    accept-lifetime 00:00:00 Nov 3 2004 duration 36000
    send-lifetime 00:00:00 Nov 3 2004 duration 36000
  key 3
    key-string exercise5b
    accept-lifetime 10:00:00 Nov 3 2004 infinite
    send-lifetime 10:00:00 Nov 3 2004 infinite
!
interface Serial0
  ip address 192.168.1.15X 255.255.255.252
  ip rip authentication mode md5
  ip rip authentication key-chain CCIE

6

Globally configure ipv6 unicast-routing. Configure the IPv6 addresses on the LAN ports. 2001:DB8:0:2::/64 is configured on the LAN shared between RTA and RTB. Configure a RIPng routing process on all IPv6 addressed interfaces.

Chapter 7

1

The EIGRP configurations are

RTA:

router eigrp 5
network 172.16.0.0
network 172.18.0.0

RTB:

router eigrp 5
network 172.16.0.0

RTC:

router eigrp 5
network 172.16.0.0
network 172.17.0.0

2

This solution uses a key chain named CCIE and key strings named exercise2a and exercise2b. Assuming today’s date is November 30, 2004, and the first key begins being used at 8:30 AM, the configurations of the serial interfaces are

key chain CCIE
key 1
key-string exercise2a
accept-lifetime 08:30:00 Dec 2 2004 08:30:00 Jan 1 2005
send-lifetime 08:30:00 Dec 2 2004 08:30:00 Jan 1 2005
key 2
key-string exercise2b
accept-lifetime 08:30:00 Jan 1 2005 infinite
send-lifetime 08:30:00 Jan 1 2005 infinite
!
interface Serial0
ip address 172.16.3.19X 255.255.255.252
ip authentication key-chain eigrp 5 CCIE
ip authentication mode eigrp 5 md5

3

The EIGRP configuration of RTD is

router eigrp 5
network 172.16.0.0
network 172.17.0.0
no auto-summary

Auto-summarization must also be turned off on RTC.

4

The EIGRP configuration of RTF is

router eigrp 5
network 172.16.0.0
network 172.18.0.0
no auto-summary

The statement ip summary-address eigrp 5 172.18.10.192 255.255.255.224 is added to RTA’s interface on subnet 172.18.10.96/27. Also, note that auto-summarization must be turned off on RTA, because of the appearance of the 172.16.0.0 network on RTF.

5

RTA can send a summary address of 172.16.3.128/25 to RTF and a summary address of 172.16.3.0/25 to RTB. All other summarization is performed automatically.

Chapter 8

1

The OSPF configurations are

RTA:

router ospf 1
network 10.0.0.0 0.0.255.255 area 0

RTB:

router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.5.0.0 0.0.255.255 area 5
area 5 virtual-link 10.100.100.9

RTC:

router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.10.0.0 0.0.255.255 area 10
network 10.30.0.0 0.0.255.255 area 30

RTD:

router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.20.0.0 0.0.255.255 area 20

RTE:

router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.15.0.0 0.0.255.255 area 15

RTF:

router ospf 1
network 10.5.0.0 0.0.255.255 area 5

RTG:

router ospf 1
network 10.10.1.58 0.0.0.0 area 10

RTH:

router ospf 1
network 10.20.100.100 0.0.0.0 area 20

network 10.20.1.0 0.0.0.255 area 20

RTI:

router ospf 1
network 10.5.0.0 0.0.255.255 area 5
network 10.35.0.0 0.0.255.255 area 35
area 5 virtual-link 10.100.100.2

RTJ:

router ospf 1
network 10.15.0.0 0.0.255.255 area 15

RTK through RTN have Frame Relay interfaces. The four interfaces to the Frame Relay network are all on the same subnet, so the OSPF network type must be either broadcast or point-to-multipoint:

RTK:

interface Serial0
encapsulation frame-relay
ip address 10.30.254.193 255.255.255.192
ip ospf network point-to-multipoint
!
router ospf 1
network 10.30.0.0 0.0.255.255 area 30

RTL:

encapsulation frame-relay
ip address 10.30.254.194 255.255.255.192
ip ospf network point-to-multipoint
!
router ospf 1
network 10.30.0.0 0.0.255.255 area 30

RTM:

encapsulation frame-relay
ip address 10.30.254.195 255.255.255.192
ip ospf network point-to-multipoint
!
router ospf 1
network 10.30.0.0 0.0.255.255 area 30

RTN:

encapsulation frame-relay
ip address 10.30.254.196 255.255.255.192
ip ospf network point-to-multipoint
!
router ospf 1
network 10.30.0.0 0.0.255.255 area 30

2

The ABR configurations are

RTB:

router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.5.0.0 0.0.255.255 area 5
area 5 virtual-link 10.100.100.9
area 0 range 10.0.0.0 255.255.0.0
area 5 range 10.5.0.0 255.255.0.0

RTC:

router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.10.0.0 0.0.255.255 area 10
network 10.30.0.0 0.0.255.255 area 30
area 0 range 10.0.0.0 255.255.0.0
area 10 range 10.10.0.0 255.255.0.0
area 30 range 10.30.0.0 255.255.0.0

RTD:

router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.20.0.0 0.0.255.255 area 20
area 0 range 10.0.0.0 255.255.0.0
area 20 range 10.20.0.0 255.255.0.0

RTE:

router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.15.0.0 0.0.255.255 area 15
area 0 range 10.0.0.0 255.255.0.0
area 15 range 10.15.0.0 255.255.0.0

RTI:

router ospf 1
network 10.5.0.0 0.0.255.255 area 5
network 10.35.0.0 0.0.255.255 area 35
area 5 virtual-link 10.100.100.2
area 0 range 10.0.0.0 255.255.0.0
area 5 range 10.5.0.0 255.255.0.0
area 35 range 10.35.0.0 255.255.0.0

3

The configurations are

RTE:

router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.15.0.0 0.0.255.255 area 15
area 15 stub

RTJ:

router ospf 1
network 10.15.0.0 0.0.255.255 area 15
area 15 stub

4

The configurations are

RTC:

router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.10.0.0 0.0.255.255 area 10
network 10.30.0.0 0.0.255.255 area 30
area 0 range 10.0.0.0 255.255.0.0
area 10 range 10.10.0.0 255.255.0.0
area 30 stub no-summary
area 30 range 10.30.0.0 255.255.0.0

RTK:

router ospf 1
network 10.30.0.0 0.0.255.255 area 30
area 30 stub

RTL:

router ospf 1
network 10.30.0.0 0.0.255.255 area 30
area 30 stub

RTM:

router ospf 1
network 10.30.0.0 0.0.255.255 area 30
area 30 stub

RTN:

router ospf 1
network 10.30.0.0 0.0.255.255 area 30
area 30 stub

5

The configurations are

RTD:

router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.20.0.0 0.0.255.255 area 20
area 20 nssa

RTH:

router ospf 1
network 10.20.100.100 0.0.0.0 area 20
area 20 nssa

6

Only one end of a point-to-point circuit needs to be configured as a demand circuit. In this solution, RTC is chosen:

interface Serial0
ip address 10.30.255.249 255.255.255.252
ip ospf demand-circuit
!
router ospf 1
network 10.0.0.0 0.0.255.255 area 0
network 10.10.0.0 0.0.255.255 area 10
network 10.30.0.0 0.0.255.255 area 30
area 0 range 10.0.0.0 255.255.0.0
area 10 range 10.10.0.0 255.255.0.0
area 30 range 10.30.0.0 255.255.0.0

Chapter 9

1

No additional OSPFv3 command is needed to include a second IPv6 prefix that has been configured on an interface in the OSPFv3 process. If OSPFv3 is configured on an interface, and a second IPv6 address is added to the interface, the second address is automatically included in the OSPFv3 process.

2

Yes, two routers can become adjacent if they are configured with different prefixes. No prefix information is included in Hellos, the source address of the Hello packet is the Link-local address. Other IPv6 addresses configured on the interfaces have no bearing on whether two routers become adjacent or not.

3

The basic router configurations are

RtrA:

ipv6 unicast-routing
int e 0/0
 ipv6 address 2001:db8:0:4::3/64
 ipv6 ospf 1 area 1
int e 0/1
 ipv6 address 2001:db8:0:5::1/64
 ipv6 ospf 1 area 1

RtrB:

ipv6 unicast-routing
int e 0/0
 ipv6 address 2001:db8:0:4::2/64
 ipv6 ospf 1 area 1

int e 0/1
 ipv6 address 2001:db8:0:6::1/64
 ipv6 ospf 1 area 1

RtrC:

ipv6 unicast-routing
int e 0/0
 ipv6 address 2001:db8:0:4::1/64
 ipv6 ospf 1 area 1

int serial 0/0
 ipv6 address 2001:db8:0:8::1/64
 ipv6 ospf 1 area 0

RtrD:

ipv6 unicast-routing
int s 0/0
 ipv6 address 2001:db8:0:8::2/64
 ipv6 ospf 1 area 0

4

To change area 1 to a totally stubby area and summarize into area 0, new router configurations are

RtrA:

ipv6 unicast-routing
int e 0/0
 ipv6 address 2001:db8:0:5::3/64
 ipv6 ospf 1 area 1
ipv6 router ospf 1
 area 1 stub

RtrB:

ipv6 unicast-routing
int e 0/0
 ipv6 address 2001:db8:0:4::2/64
 ipv6 ospf 1 area 1
ipv6 router ospf 1
 area 1 stub

RtrC:

ipv6 unicast-routing
int e 0/0
 ipv6 address 2001:db8:0:4::1/64
 ipv6 ospf 1 area 1
int serial 0/0
 ipv6 address 2001:db8:0:8::1/64
 ipv6 ospf 1 area 0
ipv6 router ospf 1
 area 1 stub no-summary
 area 1 range 2001:db8:0:10::/61

Chapter 10

1

This solution uses a System ID of 0000.1234.abcX, where X is a number that makes the router unique within the IS-IS domain. The System ID is six octets, which is required by Cisco IOS. The minimum NET length is eight octets, one of which is the SEL, so the area address is a one-octet number corresponding to the area number shown in Table 10-6. The configurations are

RTA:

interface Ethernet0
ip address 192.168.1.17 255.255.255.240
ip router isis
!
interface Ethernet1
ip address 192.168.1.50 255.255.255.240
ip router isis
!
router isis
net 00.0000.1234.abc1.00
is-type level-1

RTB:

interface Ethernet0
ip address 192.168.1.33 255.255.255.240
ip router isis
!
interface Ethernet1
ip address 192.168.1.51 255.255.255.240
ip router isis
!
router isis
net 00.0000.1234.abc2.00
is-type level-1

RTC:

interface Ethernet0
ip address 192.168.1.49 255.255.255.240
ip router isis
!
interface Serial0
ip address 192.168.1.133 255.255.255.252
ip router isis
!
router isis
net 00.0000.1234.abc3.00

RTD:

interface Serial0
ip address 192.168.1.134 255.255.255.252
ip router isis
!
interface Serial1
ip address 192.168.1.137 255.255.255.252
ip router isis
!
router isis
net 02.0000.1234.abc4.00
is-type level-2-only

RTE:

interface Serial0
ip address 192.168.1.142 255.255.255.252
ip router isis
!
interface Serial1
ip address 192.168.1.145 255.255.255.252
ip router isis
!
interface Serial2
ip address 192.168.1.138 255.255.255.252
ip router isis
!
router isis
net 02.0000.1234.abc5.00
is-type level-2-only

RTF:

interface Serial0
ip address 192.168.1.141 255.255.255.252
ip router isis
!
interface Serial1
ip address 192.168.1.158 255.255.255.252
ip router isis
!
router isis
net 02.0000.1234.abc6.00
is-type level-2-only

RTG:

interface Ethernet0
ip address 192.168.1.111 255.255.255.224
ip router isis
!
interface Serial0
ip address 192.168.1.157 255.255.255.252
ip router isis
!
router isis
net 01.0000.1234.abc7.00

RTH:

interface Ethernet0
ip address 192.168.1.73 255.255.255.224
ip router isis
!
interface Ethernet1
ip address 192.168.1.97 255.255.255.224
ip router isis
!
router isis
net 01.0000.1234.abc8.00
is-type level-1

RTI:

interface Ethernet0
ip address 192.168.1.225 255.255.255.248
ip router isis
!
interface Ethernet1
ip address 192.168.1.221 255.255.255.248
ip router isis
!
interface Serial0
ip address 192.168.1.249 255.255.255.252
ip router isis
!
interface Serial1
ip address 192.168.1.146 255.255.255.252
ip router isis
!
router isis
net 03.0000.1234.abc9.00

RTJ:

interface Ethernet0
ip address 192.168.1.201 255.255.255.248
ip router isis
!
interface Ethernet1
ip address 192.168.1.217 255.255.255.248
ip router isis
!
router isis
net 03.0000.1234.abca.00
is-type level-1

RTK:

interface Ethernet0
ip address 192.168.1.209 255.255.255.248
ip router isis
!
interface Serial0
ip address 192.168.1.250 255.255.255.252
ip router isis
!
router isis
net 03.0000.1234.abcb.00
is-type level-1

2

The configurations are

RTA:

ipv6 unicast-routing
interface Ethernet0
ip address 192.168.1.17 255.255.255.240
ip router isis
ipv6 address 2001:db8:0:10::1/64
ipv6 router isis
!
interface Ethernet1
ip address 192.168.1.50 255.255.255.240
ip router isis
ipv6 address 2001:db8:0:30::2/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc1.00
is-type level-1
metric-style wide
address-family ipv6
multi-topology

RTB:

ipv6 unicast-routing
interface Ethernet0
ip address 192.168.1.33 255.255.255.240
ip router isis
ipv6 address 2001:db8:0:20::1/64
ipv6 router isis
!
interface Ethernet1
ip address 192.168.1.51 255.255.255.240
ip router isis
ipv6 address 2001:db8:0:30::3/64
ipv6 router isis

!
router isis
net 00.0000.1234.abc2.00
is-type level-1
metric-style wide
address-family ipv6
multi-topology

RTC:

ipv6 unicast-routing
interface Ethernet0
ip address 192.168.1.49 255.255.255.240
ip router isis
ipv6 address 2001:db8:0:30::1/64
ipv6 router isis
!
interface Serial0
ip address 192.168.1.133 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:84::1/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc3.00
metric-style wide
address-family ipv6
multi-topology

RTD:

ipv6 unicast-routing
interface Serial0
ip address 192.168.1.134 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:84::2/64
ipv6 router isis
!
interface Serial1
ip address 192.168.1.137 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:88::1/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc4.00
is-type level-2-only
metric-style wide
address-family ipv6
multi-topology

RTE:

ipv6 unicast-routing
interface Serial0
ip address 192.168.1.142 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:8c::2/64
ipv6 router isis
!
interface Serial1
ip address 192.168.1.145 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:90::1/64
ipv6 router isis
!
interface Serial2
ip address 192.168.1.138 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:88::2/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc5.00
is-type level-2-only
metric-style wide
address-family ipv6
multi-topology

RTF:

ipv6 unicast-routing
interface Serial0
ip address 192.168.1.141 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:8c::1/64
ipv6 router isis
!
interface Serial1
ip address 192.168.1.158 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:9c::2/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc6.00
is-type level-2-only
metric-style wide
address-family ipv6
multi-topology

RTG:

ipv6 unicast-routing
interface Ethernet0
ip address 192.168.1.111 255.255.255.224
ip router isis
ip router clns
ipv6 address 2001:db8:0:60::f/64
ipv6 router isis
!
interface Serial0
ip address 192.168.1.157 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:9c::1/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc7.00
metric-style wide
address-family ipv6
multi-topology

RTH:

ipv6 unicast-routing
interface Ethernet0
ip address 192.168.1.73 255.255.255.224
ip router isis
ipv6 address 2001:db8:0:40::9/64
ipv6 router isis
!
interface Ethernet1
ip address 192.168.1.97 255.255.255.224
ip router isis
ip router clns
ipv6 address 2001:db8:0:60::1/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc8.00
is-type level-1
metric-style wide
address-family ipv6
multi-topology

RTI:

ipv6 unicast-routing
interface Ethernet0
ip address 192.168.1.225 255.255.255.248
ip router isis
ipv6 address 2001:db8:0:e0::1/64
ipv6 router isis
!
interface Ethernet1
ip address 192.168.1.221 255.255.255.248
ip router isis
ipv6 address 2001:db8:0:d8::5/64
ipv6 router isis
!
interface Serial0
ip address 192.168.1.249 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:f8::1/64
ipv6 router isis
!
interface Serial1
ip address 192.168.1.146 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:90::2/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc9.00
metric-style wide
address-family ipv6
multi-topology

RTJ:

ipv6 unicast-routing
interface Ethernet0
ip address 192.168.1.201 255.255.255.248
ip router isis
ipv6 address 2001:db8:0:c8::1/64
ipv6 router isis
!
interface Ethernet1
ip address 192.168.1.217 255.255.255.248
ip router isis
ipv6 address 2001:db8:0:d8::1/64
ipv6 router isis
!
router isis
net 00.0000.1234.abca.00
is-type level-1
metric-style wide
address-family ipv6
multi-topology

RTK:

ipv6 unicast-routing
interface Ethernet0
ip address 192.168.1.209 255.255.255.248
ip router isis
ipv6 address 2001:db8:0:d0::1/64
ipv6 router isis
!
interface Serial0
ip address 192.168.1.250 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:f8::2/64
ipv6 router isis
!
router isis
net 00.0000.1234.abcb.00
is-type level-1
metric-style wide
address-family ipv6
multi-topology

3

The configurations are

RTD:

Ipv6 unicast-routing
Key chain Fair
 Key 1
 Key-string Eiffel

interface Serial0
ip address 192.168.1.134 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:84::2/64
ipv6 router isis
!
interface Serial1
ip address 192.168.1.137 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:88::1/64
ipv6 router isis
authentication key-chain Fair level-2
authentication mode md5 level-2

!
router isis
net 00.0000.1234.abc4.00
is-type level-2-only
metric-style wide
address-family ipv6
multi-topology

RTE:

Ipv6 unicast-routing
Key chain Fair
 Key 1
 Key-string Eiffel
Key chain Paris
Key 1
 Key-string Tower
interface Serial0
ip address 192.168.1.142 255.255.255.252
ip router isis
ipv6 address 2001:db7:0:8c::2/64
ipv6 router isis
authentication key-chain Paris level-2
authentication mode md5 level-2
!
interface Serial1
ip address 192.168.1.145 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:90::1/64
ipv6 router isis
!
interface Serial2
ip address 192.168.1.138 255.255.255.252
ip router isis ipv6 address 2001:db8:0:88::2/64
ipv6 router isis
authentication key-chain Fair level-2
authentication mode md5 level-2
!
router isis
net 00.0000.1234.abc5.00
is-type level-2-only
metric-style wide
address-family ipv6
multi-topology

RTF:

Ipv6 unicast-routing
Key chain Paris
Key 1
 Key-string Tower
interface Serial0
ip address 192.168.1.141 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:8c::1/64
ipv6 router isis
authentication key-chain Paris level-2
authentication mode md5 level-2
!
interface Serial1
ip address 192.168.1.158 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:9c::2/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc6.00
is-type level-2-only
metric-style wide
address-family ipv6
multi-topology

4

The configurations are

RTG:

Ipv6 unicast-routing
interface Ethernet0
ip address 192.168.1.111 255.255.255.224
ip router isis
ipv6 address 2001:db8:0:96::f/64
ipv6 router isis
ip router clns
!
interface Serial0
ip address 192.168.1.157 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:9c::1/64
ipv6 router isis!
router isis
net 00.0000.1234.abc7.00
area-password Scotland
metric-style wide
address-family ipv6
multi-topology

RTH:

Ipv6 unicast-routing
interface Ethernet0
ip address 192.168.1.73 255.255.255.224
ip router isis
ipv6 address 2001:db8:0:40::9/64
ipv6 router isis
!
interface Ethernet1
ip address 192.168.1.97 255.255.255.224
ip router isis
ip router clns
ipv6 address 2001:db8:0:60::1/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc8.00
is-type level-1
area-password Scotland
metric-style wide
address-family ipv6
multi-topology

5

The configurations are

RTC:

Ipv6 unicast-routing
Key chain Austria
Key 1
 Key-string Vienna

interface Ethernet0
ip address 192.168.1.49 255.255.255.240
ip router isis
ipv6 address 2001:db8:0:30::1/64
ipv6 router isis
!
interface Serial0
ip address 192.168.1.133 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:84::1/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc3.00

authentication key-chain Austria level-2
authentication mode text
metric-style wide
address-family ipv6
multi-topology

RTD:

Ipv6 unicast-routing
Key chain Fair
 Key 1
 Key-string Eiffel

Key chain Austria
Key 1
 Key-string Vienna

interface Serial0
ip address 192.168.1.134 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:84::2/64
ipv6 router isis
!
interface Serial1
ip address 192.168.1.137 255.255.255.252
ip router isis
authentication key-chain Fair level-2
authentication mode md5 level-2
ipv6 address 2001:db8:0:88::1/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc4.00
is-type level-2-only
authentication key-chain Austria level-2
authentication mode text
metric-style wide
address-family ipv6
multi-topology

RTE:

Ipv6 unicast-routing
Key chain Fair
 Key 1
 Key-string Eiffel

Key chain Paris
Key 1
 Key-string Tower

Key chain Austria
Key 1
 Key-string Vienna
interface Serial0
ip address 192.168.1.142 255.255.255.252
ip router isis
authentication key-chain Paris level-2
authentication mode md5 level-2
 ipv6 address 2001:db8:0:8c::2
 ipv6 routing isis
!
interface Serial1
ip address 192.168.1.145 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:90::1/64
ipv6 router isis
!
interface Serial2
ip address 192.168.1.138 255.255.255.252
ip router isis
authentication key-chain Fair level-2
authentication mode md5 level-2
ipv6 address 2001:db8:0:88::2/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc5.00
is-type level-2-only
authentication key-chain Austria level-2
authentication mode text
metric-style wide
address-family ipv6
multi-topology

RTF:

Ipv6 unicast-routing
Key chain Paris
Key 1
 Key-string Tower

Key chain Austria
Key 1
 Key-string Vienna

interface Serial0
ip address 192.168.1.141 255.255.255.252
ip router isis
authentication key-chain Paris level-2
authentication mode md5 level-2
ipv6 address 2001:db8:0:8c::1/64
ipv6 router isis
!
interface Serial1
ip address 192.168.1.158 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:9c::2/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc6.00
is-type level-2-only
authentication key-chain Austria level-2
authentication mode text
metric-style wide
address-family ipv6
multi-topology

RTG:

Ipv6 unicast-routing
Key chain Austria
Key 1
 Key-string Vienna
interface Ethernet0
ip address 192.168.1.111 255.255.255.224
ip router isis
ip router clns
ipv6 address 2001:db8:0:96::f/64
ipv6 router isis
!
interface Serial0
ip address 192.168.1.157 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:9c::1/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc7.00
area-password Scotland
authentication key-chain Austria level-2
authentication mode text
metric-style wide
address-family ipv6
multi-topology

RTI:

Ipv6 unicast-routing
Key chain Austria
Key 1
 Key-string Vienna
interface Ethernet0
ip address 192.168.1.225 255.255.255.248
ip router isis
ipv6 address 2001:db8:0:e0::1/64
ipv6 router isis
!
interface Ethernet1
ip address 192.168.1.221 255.255.255.248
ip router isis
ipv6 address 2001:db8:0:d8::5/64
ipv6 router isis
!
interface Serial0
ip address 192.168.1.249 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:f8::1/64
ipv6 router isis
!
interface Serial1
ip address 192.168.1.146 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:90::2/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc9.00
authentication key-chain Austria level-2
authentication mode text
metric-style wide
address-family ipv6
multi-topology

6

The configurations are

RTC:

Ipv6 unicast-routing
Key chain Austria
Key 1
 Key-string Vienna
interface Ethernet0
ip address 192.168.1.49 255.255.255.240
ip router isis
ipv6 address 2001:db8:0:30::1/64
ipv6 router isis
!
interface Serial0
ip address 192.168.1.133 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:84::1/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc3.00
summary-address 192.168.1.0 255.255.255.192
authentication key-chain Austria level-2
authentication mode text
metric-style wide
address-family ipv6
multi-topology
summary-prefix 2001:db8::/58

RTG:

Ipv6 unicast-routing
Key chain Austria
Key 1
 Key-string Vienna
interface Ethernet0
ip address 192.168.1.111 255.255.255.224
ip router isis
ip router clns
ipv6 address 2001:db8:0:96::f/64
ipv6 router isis
!
interface Serial0
ip address 192.168.1.157 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:9c::1/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc7.00
area-password Scotland
authentication key-chain Austria level-2
authentication mode text
metric-style wide
summary-address 192.168.1.64 255.255.255.192
address-family ipv6
multi-topology
summary-prefix 2001:db8:0:40::/58

RTI:

Ipv6 unicast-routing
Key chain Austria
Key 1
 Key-string Vienna
interface Ethernet0
ip address 192.168.1.225 255.255.255.248
ip router isis
ipv6 address 2001:db8:0:e0::1/64
ipv6 router isis
!
interface Ethernet1
ip address 192.168.1.221 255.255.255.248
ip router isis
ipv6 address 2001:db8:0:d8::5/64
ipv6 router isis
!
interface Serial0
ip address 192.168.1.249 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:f8::1/64
ipv6 router isis
!
interface Serial1
ip address 192.168.1.146 255.255.255.252
ip router isis
ipv6 address 2001:db8:0:90::2/64
ipv6 router isis
!
router isis
net 00.0000.1234.abc9.00
authentication key-chain Austria level-2
authentication mode text
metric-style wide
summary-address 192.168.1.192 255.255.255.192
address-family ipv6
multi-topology
summary-prefix 2001:db8:0:c0::/58

Chapter 11

1

RIP does not advertise subnet 172.16.1.144/28. To remedy this problem, a static route is entered to that subnet but with a 27-bit mask. Because the mask references RTB’s E0 interface, it is redistributed into RIP automatically.

interface Ethernet0
ip address 172.16.1.146 255.255.255.240
ipv6 address 2001:db8:0:190::2/64
ipv6 ospf 1 area 0
!
interface Ethernet1
ip address 172.16.1.98 255.255.255.224
ipv6 address 2001:db8:0:160::2/64
ipv6 rip ripdomain enable
!
router ospf 1
redistribute rip metric 50 subnets
network 172.16.1.0 0.0.0.255 area 0
!
router rip
redistribute ospf 1 metric 2
passive-interface Ethernet0
network 172.16.0.0
!
ipv6 router rip ripdomain
redistribute ospf 1 metric 2
ipv6 router ospf
redistribute rip ripdomain metric 50

ip classless
ip route 172.16.1.128 255.255.255.224 Ethernet0

2

RTB’s configuration is

ipv6 router rip ripdomain
redistribute ospf 1 metric 2

ipv6 router ospf
redistribute rip ripdomain metric 50
summary-prefix 2001:db8:0:200::/48

3

RTB’s configuration is

interface Ethernet0
ip address 172.16.1.146 255.255.255.240
ip router isis
ipv6 address 2001:db8:0:190::2/64
ipv6 router isis
!
interface Ethernet1
ip address 172.16.1.98 255.255.255.224
ip summary-address eigrp 1 172.16.1.128 255.255.255.128
ipv6 address 2001:db8:0:160::2/64
ipv6 rip ripdomain enable
!
router eigrp 1
redistribute isis level-1 metric 10000 1000 255 1 1500
passive-interface Ethernet0
network 172.16.0.0
!
router isis
net 00.0000.1234.abc1.00
summary-address 172.16.2.0 255.255.255.0
redistribute eigrp 1 metric 20 metric-type external level-1
address-family ipv6
summary-prefix 2001:db8:0:200::/48
redistribute rip metric 20 metric-type external level-1
!
ipv6 router rip ripdomain
redistribute isis metric 5

Chapter 13

1

RTA’s configuration is

router rip
redistribute eigrp 1 metric 3
passive-interface Ethernet0
passive-interface Ethernet1
network 172.16.0.0
distribute-list 1 in Ethernet3
!
router eigrp 1
redistribute rip metric 10000 1000 255 1 1500
passive-interface Ethernet2
passive-interface Ethernet3
network 172.16.0.0!
access-list 1 deny 172.16.12.0
access-list 1 permit any

2

RTA’s configuration is

router rip
redistribute eigrp 1 metric 3
passive-interface Ethernet0
passive-interface Ethernet1
network 172.16.0.0
distribute-list 2 out Ethernet2
!
router eigrp 1
redistribute rip metric 10000 1000 255 1 1500
passive-interface Ethernet2
passive-interface Ethernet3
network 172.16.0.0
!
access-list 2 deny 172.16.10.0
access-list 2 permit any

3

RTA’s configuration is

router rip
redistribute eigrp 1 metric 3
passive-interface Ethernet0
passive-interface Ethernet1
network 172.16.0.0
distribute-list 3 out eigrp 1
!
router eigrp 1
redistribute rip metric 10000 1000 255 1 1500
passive-interface Ethernet2
passive-interface Ethernet3
network 172.16.0.0
!
access-list 3 permit 172.16.2.0
access-list 3 permit 172.16.8.0
access-list 3 permit 172.16.9.0

4

RTA’s configuration is

router rip
redistribute eigrp 1 metric 3
passive-interface Ethernet0
passive-interface Ethernet1
network 172.16.0.0
!
router eigrp 1
redistribute rip metric 10000 1000 255 1 1500
passive-interface Ethernet2
passive-interface Ethernet3
network 172.16.0.0
distribute-list 4 out Ethernet0
!
access-list 4 permit 172.16.1.0
access-list 4 permit 172.16.2.0
access-list 4 permit 172.16.3.0
access-list 4 permit 172.16.7.0
access-list 4 permit 172.16.8.0
access-list 4 permit 172.16.9.0

5

The distribute list configured under the RIPng process is

ipv6 router rip ripname
distribute-list prefix-list listname out ethernet2
!
ipv6 prefix-list listname seq 5 deny 2001:DB8:0:A::/63 le 64
ipv6 prefix-list listname seq 10 permit ::/0 le 128

6

EIGRP assigns a higher distance (170) to external routes than to internal routes (90). If any destination within the EIGRP domain is advertised into EIGRP from IS-IS, it will be ignored unless the internal route to the destination fails. Therefore, the EIGRP distances do not have to be manipulated. The distance statements under the IS-IS configurations of RTC and RTD follow:

RTC:

distance 115
distance 170 192.168.10.254 0.0.0.0 1
!
access-list 1 permit any

RTD:

distance 115
distance 170 192.168.10.249 0.0.0.0 1
distance 170 192.168.10.241 0.0.0.0 1
!
access-list 1 permit any

7

The distance statement under the IS-IS configuration of RTD is

distance 115
distance 255 192.168.10.241 0.0.0.0 1
!
access-list 1 permit any

8

The distance statement under RTC’s EIGRP configuration is distance eigrp 90 90

Chapter 14

1

RTA’s configuration is

interface Serial0
ip address 172.16.14.6 255.255.255.252
ip policy route-map Exercise1
!
interface Serial1
ip address 172.16.14.10 255.255.255.252
ip policy route-map Exercise1
!
access-list 1 permit 172.16.1.0 0.0.0.127
access-list 2 permit 172.16.1.128 0.0.0.127
!
route-map Exercise1 permit 10
match ip address 1
set ip next-hop 172.16.14.17
!
route-map Exercise1 permit 20
match ip address 2
set ip next-hop 172.16.14.13

2

RTA’s configuration is

interface Serial0
ip address 172.16.14.6 255.255.255.252
ip policy route-map Exercise2A
!
interface Serial1
ip address 172.16.14.10 255.255.255.252
ip policy route-map Exercise2B
!
access-list 1 permit 172.16.1.64 0.0.0.63
!
route-map Exercise2 permit 10
match ip address 1
set ip next-hop 172.16.14.13
!
route-map Exercise2B permit 10
match ip address 1
set ip next-hop 172.16.14.17

3

RTA’s configuration is

interface Serial2
ip address 172.16.14.18 255.255.255.252
ip access-group 101 in
ip policy route-map Exercise3
!
interface Serial3
ip address 172.16.14.14 255.255.255.252
ip access-group 101 in
ip policy route-map Exercise3
!
access-list 101 permit udp any 172.168.1.0 0.0.0.255
access-list 101 permit tcp any eq smtp 172.16.1.0 0.0.0.255
access-list 102 permit tcp any eq smtp 172.16.1.0 0.0.0.255
access-list 103 permit udp any 172.168.1.0 0.0.0.255
!
route-map Exercise3 permit 10
match ip address 102
set ip next-hop 172.16.14.9
!
route-map Exercise3 permit 20
match ip address 103
set ip next-hop 172.16.14.5

4

The OSPF configuration is

router ospf 1
redistribute eigrp 1 route-map Exercise4
network 192.168.1.0 0.0.0.255 area 16
!
access-list 1 permit 10.201.100.0

!
route-map Exercise4 deny 10
match ip address 1
!
route-map Exercise4 permit 20
match route-type internal
set metric 10
set metric-type type-1
!
route-map Exercise4 permit 30
match route-type external
set metric 50
set metric-type type-2

5

The EIGRP configuration is

router eigrp 1
redistribute ospf 1 route-map Exercise5
network 192.168.100.0
!
access-list 1 permit 192.168.1.0
access-list 1 permit 192.168.2.0
access-list 1 permit 192.168.3.0
!
route-map Exercise5 permit 10
match ip address 1
match route-type internal
set metric 10000 100 255 1 1500
!
route-map Exercise5 permit 30
match ip address 1
match route-type external
set metric 10000 10000 255 1 1500

..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset